Selection is the most useful thing you can
learn in Photoshop.

A selection enables you to choose which ar-
eas of a photograph you are working on
which will allow to do hundreds of very use-
ful things, here are just a few examples:

1) adjust the colour of somebody's T-
Shirt without affecting the rest of the
photo

2) Removing an unwanted object from a
photograph

3) Removing the whole background from
an object (isolation)

A selection is the basis of nearly every pro-
ject In Photoshop.

This tutorial will start in a very basic manor,
and will build on knowledge you have gained.
As a result the sections towards the end are
a lot shorter as a more knowledge is as-
sumed.

Even if you have knowledge of Photoshop it
would be worth Skim-reading from the be-
ginning to make sure you know the building
blocks to proceed to the next level.

I am using Photoshop CS for Windows XP,
although if you are using something slightly
different then 95% of this tutorial will proba-
bly still apply.

Each section is dedicated to one tool, and will
only take 5- 10 Minutes to read. Hopefully
this tutorial is quick and easy to follow.
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The easiest and quickest way to make a
complex selection is the magic wand. Unfor-
tunately its also the easiest way to make a
bad selection.

This is a great tool to start your selection
with, but results can be shocking so its nor-
mal to combine the magic wand with other
selection methods.

Step 1
Load up Photoshop and click the magic
wand (shown left) If your not sure what
a tool does leave your mouse over it for
a short while and a helpful tool tip will
appear.

Step 2
You will see the menu opposite appear
at the top of your screen. This is the
place all the tool options appear. I have
split the menu here so it fits on the page
better.

Make sure that “Anti-aliased” is ticked,
the will create a smoother, better selec-
tion. Also check “Contiguous” is ticked,
this means only pixels in the area you
clicked will be affected

Step 3

Click the area you need selecting, and
the magic wand does its best. The wand
analyses the area you clicked, and se-
lects all the similar colours it finds from
the colour you initially clicked.

You can adjust how much it selects by
typing a number between 0-255 in the
tolerance option box. A higher tolerance
will include more colour hues, and will
select more. (see examples on left)

Step 4

Getting a good tolerance setting first
time takes practise, keep adjusting until
you get the best selection you can. You
will soon get a good idea of how much
tolerance to use.
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Okay, so that the theory. In reality those
simple steps will only work if you have
taken a picture that is on a single colour
background.

I'm going to show a few tricks to im-
prove the usefulness of the magic wand
for making selections on an average,
background.

Step 5

I clicked once on the background with a
tolerance of 25. Not a bad start, but if
you look closely you will notice a few bits
in the middle of the selection that have
been missed.

I'm going to deselect and try again
(image > deselect ) or (Ctrl + D)

This removes the current selection.

Step 6

This selection with a tolerance of 50 in-
cluded more of the background. This is a
good start.

Did you know you can add to a selection,
or remove areas of a selection with the
magic wand? The tool menu screenshot
on page 1 has 4 icons, that allow you to
subtract, and add to selections. I'm go-
ing to teach you the quick way so you
wont be using these.

Step 7

Adding to a selection :

Holding down "“SHIFT” when you click
with the magic wand will add you your
current selection

Removing from selection :

Holding down “ALT” when you click with
the magic wand will remove part of your
selection

Each time you add or remove parts of a
selection with the magic wand you can
change the tolerance level !
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Step 8

I continued to add to the selection, hold-
ing down the SHIFT key, I did not
change the tolerance, so the selection
spilled onto the light area of the fish.
(left)

I soon fixed this by changing the toler-
ance to 25, then holding down ALT and
clicking the part of the selection 1
needed to remove.

Step 9

Okay, you have learnt how to add and
remove from a  selection using the
magic wand. The truth is, that on this
image the magic wand didn't do a great
job. The edge between the water and
the fish is not different enough to be
very successful.

You can tidy up this basic selection, us-
ing other selection methods, like the
“mask”. Most people will mix and match
selection methods until they get a final
result they are happy with.

Although I have in no way finished the
selection for the above fish, The tutorial
on the magic wand will end, you will
learn how to improve on this initial se-
lection later in the tutorial.

NOTE :

It often makes more sense to select the
background with the magic wand, if you
want the object selected then go to
Select > Invert

With this in mind it does not matter what
you decide to select, the object or the
background. Which ever is easier.



Improving
The selction

I will go into more detail about manually
improving the selection, But I thought
this would be a good place to give a few
hints about automatically getting a bet-
ter selection.

OPTIONS

Select > Modify > Smooth
This option, as the name suggests will
make sharp corners more gradual.

Select > Modify > Expand or Con-
tract

Makes the current selection become big-
ger or smaller by a stated number of
pixels. If I have selected the object with
the magic want I always expand by 1-2
pixels before I delete the background

If I have the background selected I al-
ways Expand the selection by 1-2 pixels.
This is to make sure all of the original
background colour is removed, you will
get a “halo” or the old background
around your object otherwise.

Select > Modify > Similar

This option looks at the selection you
already have, then guesses at any stray
pixels that should also be selected. Also
useful, and often worth doing.

Select > Feather

You can make the edge of the selection
softer using this option, Put in a value
(about 1-2 pixels is all you need nor-
mally) before you delete the back-
ground. This will allow a nice smooth
anti-aliased edge.
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Another quick selection method, this
however allows more control over the
area than the magic wand. It will create
a crude “working selection”

Step 1

By clicking and holding on the lasso but-
ton, a sub-menu will pop up containing
the magnetic lasso. This tool again relies
on the contrast of two objects to auto-
matically make a selection.

Step 2

When you select the magnetic lasso tool,
the tool options menu again changes.
Lets have a closer look at what all these
options are.

The first part of the menu is the same as
the magic wand, the four icons that we
wont be using that allow you to add and
subtract from selections (we will use ALT
and SHIFT to get the job done quicker)

Feather, although we have not com-
mented on it yet is available on all selec-
tion tools, It allows you to adjust the
softness of the selection—In this tutorial
I will be teaching you to use masks
which allow you a lot more control but
do the same job.

Width, is the amount of pixels each side
of your initial click that Photoshop will
analyse the contrast of.

Edge Contrast, For subtle images that
do not have a lot of contrast between
the edges use a low number.

Frequency, the higher the number the
more fastening points Photoshop lays
down, about 50 is a good number.
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Another quick selection method, this
however allows more control over the
area than the magic wand. It will create
a crude “working selection”

Step 3

Okay here is a high contrast image to try
it out on. The background is a nice dark
blue, and the object is white. Perfect for
the magnetic lasso.

Click at the edge of the petal to make a
start, you do not need to hold the mouse
button down.

Step 4

With your selection started move around
the petal, Photoshop automatically
draws a selection. Try and move your
mouse pointer around the petal as
closely as you can.

If the selection start to “stray” (go
where you do not want it to) then you
can click the mouse button to add a fas-
tening point.

Step 5

A selection can be finished by double
clicking, or by going all the way around
an object and then clicking on the first
fastening point that was created.

Step 6

You will normally find a few areas that
need correcting (tip of the leaf for the
image on the left) , But this tool is useful
to make a fast and easy selection.

Keep reading to find techniques to cor-
rect and improve a magnetic lasso selec-
tion.
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The final semi automatic selection tool
before we move onto making manual
selections, and correcting the results
achieved with the automatic selection
tools.

Step 1
The colour range menu can be found in
Select > Color Range...

This tool is similar to the magic wand,
but gives you a preview of what will be
selected. It works over the whole image,
so could be used to select everything
blue in an image.

Step 2

On this picture of a spark plug that was
isolated on white, I have clicked once on
the plug. The area that shows up white
is what will be selected. You can adjust
the slider called “fuzziness” to include
more or less of the object. You will see a
live preview as you work.

Make sure the drop down menu reads
“Sampled Colours”

Step 3

Clicking Ok I got the selection on the
left. As you can see all the dark colours
on the spark plug have been selected,
however the highlights on the metal
have been missed off.



The
“Golour Range
selection”
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Step 4

You can fine tune the selection easily,
Notice the colour dropper icons in the
colour range menu, they have a + and—
symbol next to them.

These work the same as pressing SHIFT
and ALT to add and subtract from a se-
lection. By using these you can fine tune
which colours will get selected.

Pressing the Invert checkbox will reverse
the selection (the background not the
sparkplug will become selected)

Step 5

The colour range does something very
different from the last two selection
methods, it has the ability to “half se-
lect” pixels.

If I clicked the white background on the
spark plug, it automatically selected the
highlights on the metal, it also half se-
lected the light grey gradient.

I have created a layer above my spark
plug and filled the selection with red.
Notice the way red spills out of the se-
lection. These are semi opaque pixels,
and the metal underneath can still be
seen.
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Extra Options

On the drop down menu you have a
number of extra option :

“Reds, Yellows, and other colours”
unsurprisingly this selects just the col-
ours that you choose.

Highlights, Midtones, and Shadows
Again as it says, this will select only
these parts of the images.

Uses

Although this is quick, it can produce a
lot of unwanted results, but again if you
used this to generate a quick rough se-
lection that you planned to improve later
it's a useful tool.
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The extract command is the most intelli-
gent of the selection aids, this is because
it requires a lot of manual input. It does
a good job but you will often need to
correct a few mistakes it makes.

Step 1

You can find the Extract Command in
“Filters > Extract”

Step 2

You need to tell Photoshop where the
edge of the object is. You do this by us-
ing the “Marker Tool” Use it to draw
around the edge of the object.

I always tick the box “Smart Highlight-
ing” This works on contrast and helps
you draw an accurate line around the
edge of the object. You can adjust the
size of the marker (brush size) and the
colour (Highlight) from the right hand
side tool options.

Step 3

As you can see on the left, the green
highlighter marks the edge of my pic-
ture. I have drawn this with Smart High-
light on, so it fits nicely to the edge.

On some areas smart highlight will not
do anything because it cannot find an
contrast, just keep going and do the
best you can.

Step 4

Once you have completely highlighted
the edge of your object, click the paint
bucket tool, and click on the are you
want to keep (the object). The object
will be filled in blue (or whatever colour
you chose)



Using “Extract”

The extract command is the most intelli-
gent of the selection aids, this is because
it requires a lot of manual input. It does
a good job but you will often need to
correct a few mistakes it makes.

Step 5

The are filled with colour is the area you
will be keeping. Click the OK button to
begin extraction. I have created a layer
below the lily and filled it with black so I
can see how good the extraction has
been.

I have found a couple of problems with
this extraction (see arrows)

The extraction tool is quick and easy to
use, however it does create quite a soft
look to the selection (even with all the
options adjusted) It's the best tool if you
want to isolate somebody's hair.

Final Word ...

Ok, so that wasn't so hard. You have the
knowledge of all the basic selection
tools, now its time to make high quality
selections.

I have pointed out the problems with
each method, but don't worry all prob-
lems can easily be fixed. The next part
of this tutorial will show you ways to im-
prove the selection.



Its
Tidy Up Time

I have constantly repeated the fact that
automatic selections need to be tidied
up. So lets do it.

The following sections will teach you to
some important selection techniques to
really make a nice clean selection.

Once you have read about correcting
and improving selections, We will move
on to drawing a manual selection using
the pen tool, and then 2 practical exam-
ples of selection.

The History Brush

To correct all the mistakes the history

brush is a very valuable tool, Will defi-
antly be required if you use the Extract
Command.

Masks
Using masks to improve selections, and
feather edges
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A bit of a life saver! Brilliant to correct
small errors in the extract tool—or any
other tool!

Step 1

We are going to correct the flower to the
left using the History brush. The first
thing you need to do is get the history
pallet up.

Windows > History

Step 2

The History Palette contains everything
that has happened to your document
since you opened it.

Your history brush is available on the
tools palette. (left)

Step 3

Now, If you have not changed the size,
or colour depth of your canvas you can
just use the history brush to “paint” ar-
eas back to their original state.

Basically the tool looks at what the im-
age was like when you opened it, and
replaces the new image with the old, re-
storing areas that you need to be re-
stored.




The
“History Brush”

A bit of a life saver! Brilliant to correct
small errors in the extract tool—or any
other tool!

Step 4

Although this is often useful, sometimes
we will change the image substantially,
and the image we opened at the start is
no longer any use to us—Don’t worry,
snapshots are the solution.

A snapshot can be created in the history
palette, you can jump to a snapshot and
your image will go to exactly the state it
was when you created the snapshot. Its
good practice to make many snapshots
as you work.

Your history brush can work from any
snapshot you create.

To make the history brush work from a
snapshot click the little box next to the
snapshot ( see picture left ) the history
brush icon appears in the box. Now Get
painting!

Step 5

With the history brush set to a small
size, carefully go over the areas the ex-
tract tool has accidentally removed.
Eventually you will end up with a good
isolation

You will probably need to be zoomed in
to 100%. You may sometimes recon-
struct areas you don't need (eg. the
background) so use the eraser tool as
well if needed.



Tiny adjustments, transparent pixels,
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Step 1

Okay quick masks are very flexible, but
they are labour intensive, so I suggest
you use one of the methods already cov-
ered to get a basic automatic selection.

| [:I | (not the extract tool as this does not
create a selection, but physically re-
moves pixels)

Get the automatic selection as good as
possible, but do not worry about it too
much. We will be using a quick mask to
tidy up the selection.

Find the quick mask buttons (see left)
they are at the bottom of the toolbar

Step 2
By clicking the button the arrow points
to you enter the quick mask mode.

By default everything that is not selected

Quick Mask Options turns red. Personally I find this a very
Color Indicates: confusing way to work, and prefer it so

® Masked Areas that everything that is red is selected. I
oA have found a lot of people who agree
with me, so I recommend you change to

el this method as you will find it easier to

: follow this tutorial. You can change back

. Opacity: | & | % at any time if you find the default easier.
To change double click the quick mask

buttons and select “color indicates : Se-
lected Area”

Press okay.
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Tiny adjustments, transparent pixels,
and gradients are a doddle with a quick
mask.

Step 3

I created the selection opposite with the
magic wand, This selection is as good as
I can get with this tool, so im going to
tidy up with the quick mask. Click the
quick mask button and the object will
turn red (see screen shot )

Step 4

You will often need to zoom in too see
any problems. If your object has any red
on it, the use the eraser tool to get rid of
it. If the background does not have red
on it then just paint it with the paint-
brush.

The great thing with a quick mask is that
you have access to all the normal paint-
ing tools, but they do not effect the im-
age but do alter the selection.

Step 5
You can also run filters on the selection.
If you go to filters > blur > Gaussian
blur You can slightly blur the red mask
creating a softer selection around the
edges.

This does the same thing as
Selection > feather but gives you
more control.



Masking
An Ohject
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Step 6

You can also select parts of a mask, this
is very useful with photographs that
have DOF (depth of field) as the object
gets further away the background blends
into the object a lot more, making it
tricky to isolate onto another colour.

Select the part of the image that has
high DOF, using the lasso tool (do it very
roughly) Now go to select > feather
and choose an option of about 20pixels

Now go to Filters > blur > Gaussian
blur and blur the mask to something
that looks similar to the amount of DOF.

Step 7
You can go around the image selecting
areas and blurring them

When you eventually delete the back-
ground you may have to press delete a
couple of times, each time you press de-
lete it will delete a few more of the semi
transparent pixels created by using the
Gaussian blur in quick mask mode, so
keep doing it until all the old background
disappears

See magnified screen shot of the petal,
no evidence of the old blue background
exists, and a slight blur to the mask cre-
ates a nice smooth anti aliased line so
that the black background on the layer
underneath shows through seamlessly.



Step 8

I realise I have not given you step by
step information, But I have given you
the practical uses behind a quick mask,
and shown you a few techniques on how
to use them.

The problem with giving a rigid step by
step instruction is that tools like this are
highly flexible, you really need to get
your hands dirty and try them, come up
with your own techniques and do things
your own way.

You have enough knowledge to fly solo
and really do things your own way. Mix
and match the different selection tech-
niqgues—you will soon be doing it with
your eyes shut.
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Rectangle and Circle Marquee. Easy to
use manual selection.

Where to find it

Holding the mouse down over the rec-
tangle marquee tool will give you the
option for a circle as well. They both
work the same so I will not be dealing
with them differently.

Options

Its often very difficult to perfectly select
a circular object with the elliptical mar-
quee tool, unless of course you know a
few tips.

Free transform... a selection!

Once you have a basic selection, you can
right click on the canvas and choose free
transform. You now get “handles” so you
can stretch the selection, rotate it, and
do whatever you like with it. Excellent to
easily make a selection perfectly fit a
circle.

Once the selection in in “free transform
mode” you can right click again to get
options like rotate, distort, and you can
adjust your selection to fit perfectly.

Adding and subtracting

As before you can add to a selection by
holding down SHIFT and subtract from it
using ALT.

Constraining

If you hold down SHIFT as you draw a
circle or rectangle, it constrains the size
to a perfect circle or perfect square.

On the toolbar you can click the drop
down menu and choose “Fixed Aspect
ratio” and this will all so constrain to a
perfect square/circle.

If you choose “fixed size” from the drop
down box you can type in the exact size
of your square/circle.
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We have already seen the magnetic
lasso, But the lasso tool also has manual
options.

Lasso Tool

This tool is your freehand option, it gives
you absolutely no help, so wherever you
move your mouse is where your selec-
tion is. You cannot make accurate selec-
tions with this tool (unless you have a
very steady hand!)

Its very useful to quickly remove areas
of a selection you don't want.

Polygonal Lasso

A very useful tool, you need to be
zoomed at 100% to make an accurate
selection with it. Click and release where
you want to start your selection. As you
move your mouse you will notice a line
follows you. Each time you click you cre-
ate a point. Point are joined using a
straight line.

To make a selection using this tool, just
click all around the edge of your object,
when you get to rounded edges you will
have to click more often so that the
curve does not get a pointy angled look
to it.



Manual Selection
“Selections to
paths”
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Creating a path from a selection is a
common thing to do, as you can save
paths with a jpeg file

Notes

Go to your Paths Palette (Windows >
paths) Notice the buttons at the bottom.
The longer arrow points to the button
that create a selection from a path, the
shorter arrow points to the button that
creates a path from a selection.

Note On The Pen Tool

The pen tool is one of the hardest tools
to master, its not strictly a selection tool
as it creates a path. However as you
have seen its easy to convert between
the two so its worth mentioning.

Although hard to master, its well worth
the effort. Its quite slow to use, but the
end result will be worth it.

Teaching the pen tool properly is outside
the scope of this tutorial (to avoid it get-
ting too long) But I will be creating an-
other tutorial soon and will attempt to
teach you the wonders of the pen tool



